Supportnet Computer
Planet of Tech

Supportnet / Forum / WindowsXP

Excel : Wenn Fromel





Frage

Hallo Ich habe eine Frage zur Wenn Formel. In einer Kollone stehen die Bezeichnungen h , ca oder cam. In einer andern Kollone muss ich die Anzahl der Produkte (Zelle C20) mal den Betrag multiplizieren. h steht für den Betrag 0.5 (Zelle A4) ca steht auch für den Betrag 0.5 (Zelle A9) und cam steht für den Betrag 0.25 (Zelle A15) Meine Logik war die folgende : Wenn in der Zelle B20 h oder ca seht, soll in der Zelle F20 die Zahl der Zelle C20 Mal die 0.50 multipliziert werden. Wenn aber in der Zelle B20 cam steht, dann soll die Zahl in der Zelle C20 Mal 0.25 mulipliziert werden.b Und dies war die Formel die ich versucht habe, die aber jedoch misslang : =SI(B20=$A$4 oder $B20=$A$9;$C20*$C$3;0);SI($B20=$A$15;$C20*$C$14;0) Könnt Ihr mir bitte da weiter helfen ?

Antwort 1 von Risatara2

Hi,
Deiner Logik folgend wäre der richtige Excel-Aufruf doch:
=Wenn(oder(b20=$A$4; $B20=$A$9);C20*0,5;wenn(b20=$A$15;C20*0,25;""))

Oder irre ich mich?
Gruß, Risatara

Antwort 2 von Mythos!

Sorry, kleine Korrektur. Ich habe Französisch mit Deutsch vermischt.
Ich meinte natürlich :

=WENN(B20=$A$4 oder $B20=$A$9;$C20*$C$3;0);WENN($B20=$A$15;$C20*$C$14;0)

Antwort 3 von Risatara2

Außer das du oder falsch angewandt hast (oder geht das bei Excel jetzt?) scheint mir alles korrekt. Oder ist eine Funktion, die Wahr zurück gibt, wenn einer der beiden Parameter wahr ergibt, also =oder(a=a;a=b) ergibt wahr..

Antwort 4 von Risatara2

Mein Fehler, deine Wenn-Formel gibt eine Null aus, wenn die erste Falsch ist, ersetze das durch die zweite Wenn-Formel.

Antwort 5 von Risatara2

Auf den Punkt gebracht:
Die richtige Formel (auf deutsch) wäre "=WENN(ODER(B20=$A$4;$B20=$A$9);$C20*$C$3;WENN($B20=$A$15;$C20*$C$14;0))"

Gruß, Risatara

Antwort 6 von Mythos!

Hallo Risatara2s

Es hat geklappt !!!

Herzlichen Dank.

Du warst mir eine grosse Hilfe.

Freundliche Grüsse

Mythos!

Antwort 7 von Risatara2

Danke für die Antwort, keine Ursache.