Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

excel-formel mit wenn-dann





Frage

hallo leute, hoffe es kann mir einer helfen, hab ein großes prob mit ner formel. ich habe ein feld in welches eine zahl zwischen 10-50 eingeben weden soll, ist der wert kleiner wie 10 bzw größer wie 50 soll 0 stehn. ist der wert z.b. 20 sollen 2 weiter werte geprüft werden. hierbei soll geprüft werden ob wert b größer als 10% oder/kleiner/gleich zum wert a ist, ist der wert b kleiner/gleich a, so soll er mit 10% multipliziert werden ist er größer als 10% zum wert a soll ein ok ausgegeben werden. sprich: zeile a7 zb wert 9 = 0 zeile a7 zb wert 20 = zeile a8 wert 20 a=1000 wert b= 800 -> ausgabe zeile a7 = 1100 zeile a8 wert 20 a=1000 wert b= 1000 ->ausgabe zeile a7 = 1100 zeile a8 wert 20 a=1000 wert b= 1100 ->ausgabe zeile a7 = ok zeile a8 wert 20 a=1000 wert b= 1500 ->ausgabe zeile a7 = ok ich hoffe mein prob. ist für alle verständlich geschildert und bedanke mich schonmal im voraus für die hilfe. gruß stefan

Antwort 1 von M.O.

Hallo Stefan,

ich habe etwas Probleme mit deiner Beschreibung und der Tabelle.

Zitat:
hierbei soll geprüft werden ob wert b größer als 10% oder/kleiner/gleich zum wert a ist, ist der wert b kleiner/gleich a, so soll er mit 10% multipliziert werden ist er größer als 10% zum wert a soll ein ok ausgegeben werden


Müsste das i1. Beispiel deiner Tabelle dann nicht so aussehen:
zeile a8 wert 20 a=1000 wert b= 800 -> ausgabe zeile a7 = 880

Und was soll ausgegeben werden, wenn der Wert b zwar größer als Wert a ist, aber nicht um 10%.

Gruß

M.O.

Antwort 2 von stefan1975

moin m.o.,

sry das ich mich jetzt erst melde aber inet funzte mal wieder nicht,
hab die tabelle überarbeitet und hier nochmal die frage.

in zeile a1 steht ein wert von z.b. 1000, in zeile b1 z.b. 800 und in zeile c1 ein wert zwischen 20-50.

ist der wert in zeile c1 kleiner/größer 20-50 soll in d1 der wert 0(null) ausgegeben werden.
liegt der werd in c1 zwischen 20-50, und b1 ist kleiner wie a1+10% so soll in d1 der wert von a1(1000) + 10% angezeigt werden (1100).
liegt der werd in b1 um 10% höher als in a1 so soll in d1 "ok" ausgegeben werden.

beispiel:

a1=1000 b1= 800 c1= 15 d1= 0 (null) da nicht zwischen 20-50
a1=1000 b1= 800 c1= 25 d1= 1100
a1=1000 b1= 1000 c1= 25 d1= 1100
a1=1000 b1= 1099 c1= 25 d1= 1100
a1=1000 b1= 1100 c1= 25 d1= ok
a1=1000 b1= 2000 c1= 25 d1= ok

der wert in b1 muß immer um 10% höher sein als der in a1, ist dies der fall dann d1= "ok" ansonsten d1 = a1+10%.

ich hoffe das diese erklärung dir/euch weiter hift.
gruß stefan

Antwort 3 von M.O.

Hallo Stefan,

schreibe in D1 folgende Formel:

=WENN(ODER(C1<20;C1>50);0;WENN(B1>=A1*110%;"ok";A1*110%))

Gruß

M.O.

Antwort 4 von stefan1975

danke m.o., funzt

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: