Supportnet Computer
Planet of Tech

Supportnet / Forum / Tabellenkalkulation

Hilfe: Will Summe bilden aus Spalte B mit Bezug zu Spalte A





Frage

Mein Problem ist wie folgt: Ich habe in Spalte A von A1 bis A13 Bezüge. Nun benötige ich eine Formel die in etwa so gestrickt sein müsste: Suche in Spalte A den 1. den Wert X und 2. den Wert Y. Wenn du die beiden Werte gefunden hast summiere von X bis Y in Spalte B. Beispiel: A B A 3,0 B 4,0 C 5,0 D 6,0 E 7,0 F 8,0 Finde A und E und bilde die Summe von 3,0 bis 7,0. Ergebnis: 25,00. Versteht ihr mein Problem. Brauche dringend HILFE! G 9,0

Antwort 1 von rainberg

Hallo,

so kann's gehen.

=SUMME(INDIREKT("B"&VERGLEICH("A";A:A;0)&":B"&VERGLEICH("E";A:A;0)))

Die Vergleichswerte kannst Du auch in Zellen schreiben und deren Bezüge in der Formel verwenden.

Gruß
Rainer

Antwort 2 von Angenehm

Hallo Rainer,

ich komm nocht drauf.

Versuche mich nochmal besser zu erklären.

Ich habe in A1 einen Text und A10 einen Text.

Die beiden Zellen möchte ich nun auswerten.

Außerdem, habe ich eine Matrix in der die beiden Werte (A1 und A10) wieder auftauchen.
Jetzt soll die Matrix durchsucht nach dem Text aus A1 und nach dem Text aus A10. Mein Ergebnis soll allerdings die danebenstehenden Werte B1 bis B10 aufsummieren.

Also:
A1 = LM-15
A10 = LM20

Matrix:
ZelleA1 = LM-15 ZelleB1 = 10
ZelleA2 = LM-16 ZelleB2 = 20
ZelleA3 = LM-17 ZelleB3 = 30
ZelleA4 = LM-18 ZelleB4 = 40
ZelleA5 = LM-19 ZelleB5 = 50
ZelleA6 = LM20 ZelleB6 = 60
ZelleA7 = LM-21 ZelleB7 = 70

Die Formel muss nun also LM-15 und LM-20 in der Matrix suchen und als Ergebnis 210 rauswerfen. Also Addition von B1 bis B6.

Kannst du mir das nochmal erklären, vielleicht ausführlicher?
Vielen Dank im Voraus.

Antwort 3 von Angenehm

Also:
Das sind die Daten aus Tabelle 1:
A1 = LM-15
A10 = LM20

Die Matrixwerte stehen in Tabelle 2.

Hatte ich vergessen zu erwähnen.

Antwort 4 von rainberg

Hallo ?,

dann passe ich Dir die Formel mal an

=SUMME(INDIREKT("B"&VERGLEICH("LM-15";A:A;0)&":B"&VERGLEICH("LM-20";A:A;0)))

Im ersten Beispiel waren die Vergleichswerte A und E und im zweiten Beispiel werden diese einfach durch LM-15 und LM20 ersetzt.

Nun sollte es aber "Klick" machen :-)

Gruß
Rainer

Antwort 5 von rainberg

Hallo ?,

nachdem Du nun das Entscheidende verraten hast, sieht die Formel (die in Tabelle1 stehen muss) so aus.

=SUMME(INDIREKT("Tabelle2!B"&VERGLEICH(A1;Tabelle2!A:A;0)&":B"&VERGLEICH(A2;Tabelle2!A:A;0)))

Gruß
Rainer

Antwort 6 von Angenehm

Ahhahahahahahaha... ich hab's endlich!

Rainer, du bist mein Held!!!
Vielen Dank!

Ich möchte kostenlos eine Frage an die Mitglieder stellen:


Ähnliche Themen:


Suche in allen vorhandenen Beiträgen: