Du bist hier::--Excel Formeln – Alle einzelnen Zeichen eines Strings anzeigen

Excel Formeln – Alle einzelnen Zeichen eines Strings anzeigen

In diesem Artikel wird ihnen erklärt, wie man in Excel ganz einfach anzeigen kann, welche Zeichen in einer Zelle verwendet worden sind.

Sie möchten, dass Excel alle Zeichen einer Zelle einzeln auflistet und dabei doppelte Zeichen nicht nochmal extra erwähnt? In diesem Artikel finden Sie zwei Formeln, die genau dafür zuständig sind.

Vorkommen wie im String:

Man hat in A1 beispielsweise einen Text oder eine Zahl, oder auch eine Verbindung aus beiden und möchte anschließend, dass in anderen Zellen die einzelnen verwendeten Zeichen aufgeführt werden. Geordnet sollen die Zeichen nach ihrem Vorkommen in A1 sein. Schreiben Sie dazu in die erste Zelle (A2), in der die Auflistung der Zeichen beginnen soll nun folgende Formel:

=WENN(ZEILEN(A$2:A2)>SUMME(N(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99)));"";TEIL(A$1;KKLEINSTE(WENN(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99);ZEILE($1:$99));ZEILEN(A$2:A2));1))

Diese Formel ist aber keine normale Formel, sondern eine Matrixformel. Um zu garantieren, dass sie richtig funktioniert müssen sie nun, nachdem Sie die Formel in A2 eingegeben haben, oben in die Bearbeitungszeile der Formel gehen. Anschließend bestätigen Sie diese Formel, ohne etwas verändert zu haben mit STRG+SHIFT+Enter.
Die Formel wird sich anschließend sofort in folgende Formel verwandeln:

{=WENN(ZEILEN(A$2:A2)>SUMME(N(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99)));"";TEIL(A$1;KKLEINSTE(WENN(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99);ZEILE($1:$99));ZEILEN(A$2:A2));1))}

Das ist die gleiche Formel, wie oben nur mit geschweiften Klammern ( {} ) am Anfang und am Ende.
In der Zelle selbst wird nun das erste Zeichen angezeigt. In meinem Fall war das ein „M“, da in A1 „Max Mustermann“ steht. Diese Zelle kopieren Sie anschließend in die anderen Zellen, in denen die Formel erscheinen soll. Fahren Sie dazu mit der Maus über die rechte untere Ecke der Zelle A2, woraufhin sich der Mauszeiger in ein Kreuz verwandeln wird. Klicken Sie nun mit der linken Maustaste und halten Sie sie gedrückt während Sie die Maus nach unten bewegen. Nach einer gewissen Anzahl an Zellen – bei mir waren es 12 – können Sie die Maus dann wieder loslassen. Jetzt stehen auch in den anderen Zellen die Zeichen.

(Zur Darstellung in Originalgröße Abbildungen anklicken)
01-excel-formeln-alle-zeichen-eines-strings-auslesen-nach-name-470.png?nocache=1308577607480

Nach Code geordnet:

Eine weitere Möglichkeit die Zeichen aufzulisten ist die, dass sie nach ihrem Code geordnet sind. Bei dieser Ordnung werden zuerst Sonderzeichen, wie Leerzeichen oder Slash aufgelistet, anschließend folgen die Zahlen, die Großbuchstaben, die Kleinbuchstaben und zum Schluss kommen Umlaute. Möchten Sie, dass ihre Zeichen so geordnet sind, so gibt es dafür selbstverständlich auch wieder eine Formel. Geben Sie dazu in A2 diese Formel ein:

=WENN(ZÄHLENWENN(A$1:A1;ZEICHEN(MAX(CODE(TEIL(A$1;SPALTE($1:$1);1)&"!"))));"";ZEICHEN(KKLEINSTE(WENN(LÄNGE(A$1)-LÄNGE(WECHSELN(A$1;ZEICHEN(ZEILE($32:$255));));ZEILE($32:$255);"");ZEILE(A1))))

Da auch dies wieder eine Matrixformel ist, müssen Sie zuerst wieder oben in die Bearbeitungszeile gehen und die Formel anschließend mit STRG+SHIFT+Enter bestätigen.
Nun wird sich die Formel wieder verwandeln und Sie sieht so aus:

{=WENN(ZÄHLENWENN(A$1:A1;ZEICHEN(MAX(CODE(TEIL(A$1;SPALTE($1:$1);1)&"!"))));"";ZEICHEN(KKLEINSTE(WENN(LÄNGE(A$1)-LÄNGE(WECHSELN(A$1;ZEICHEN(ZEILE($32:$255));));ZEILE($32:$255);"");ZEILE(A1))))}

Haben Sie alles richtig gemacht, so erscheint in dieser Zelle das erste Zeichen. Sollte hier nichts stehen, wundern Sie sich nicht. Denn hier steht trotzdem etwas, es ist nur das Leerzeichen, welches eben in den Codeordnung zuerst genannt wird. Diese Formel muss anschließend natürlich auch auf die anderen Zellen kopiert werden. Fahren Sie also nun wieder mit der Maus über die rechte untere Ecke, woraufhin sich der Mauszeiger in ein Kreuz verwandelt. Dann klicken Sie und halten die Maus gedrückt. Währenddessen fahren Sie mit der Maus nach unten. In meinem Fall reicht bis Zelle 12. Jetzt lassen Sie die Maus wieder los und Sie sehen, dass jetzt hier alle oben aufgeführten Zeichen aufgelistet sind. Nun haben Sie die Zeichen des Texts aus A1 in der Codeordnung aufgelistet.

02-excel-formeln-alle-zeichen-eines-strings-auslesen-nach-code-470.png?nocache=1308577627512 

Nun wissen Sie, wie einfach es ist mit mehreren Formeln alle verwendeten Zeichen eines Strings aufzulisten. Selbst die Ordnung der Liste können Sie bestimmen.

Von |2018-07-25T14:24:21+00:00Juni 21st, 2011|Kategorien: Tabellenkalkulation|0 Kommentare

Über den Autor:

Hinterlassen Sie einen Kommentar