Du bist hier::--Excel Formeln – Personen mit einem bestimmten Alter zählen

Excel Formeln – Personen mit einem bestimmten Alter zählen

In diesem Excel Artikel werde ich ihnen zeigen, wie man mithilfe einer einzigen Formel in Excel die Anzahl an Personen mit einem bestimmten Alter anzeigen kann, wenn nur ihr Geburtsdatum bekannt ist.

Das Excel viele Dinge zählen kann, wussten Sie wahrscheinlich bereits. Jedoch kann es nicht nur Zellen zählen, die eine bestimmte Zahl überschritten haben, es kann auch mit Daten umgehen. Vom Prinzip her ist das für das Programm dasselbe, da es das Datum einfach in eine Zahl umwandelt, jedoch ist es für den Benutzer deutlich angenehmer anzuschauen.

Beginn:

Zu Beginn tragen Sie in ihre Excel Tabelle die Geburtstage der gewünschten Personen ein. Zur schöneren Übersicht und der besseren Verständlichkeit bietet es sich an, wenn Sie die Spalte A für die Namen der Personen nutzen und in Spalte B dann die Geburtstage von ihnen eintragen. Genauso habe ich es in meinem Beispiel auch gewählt. Möchten Sie der Anleitung bestmöglich folgen, so empfehle ich ihnen es auch so zu machen, damit Sie die unten aufgeführten Formeln dann nicht extra noch anpassen müssen, sondern einfach so übernehmen können.

(Zur Darstellung in Originalgröße Abbildungen anklicken)
01-excel-formeln-personen-mit-bestimmten-alter-zaehlen-beginn-470.png?nocache=1308758960893

Berechnung der Anzahl der Personen mit einem bestimmten Alter:

Nachdem Sie nun alle relevanten Daten eingetragen haben, können Sie nun mit der Ausgabe der Anzahl der Personen beginnen, die zwischen einem bestimmten Alter liegen. Ich habe für mein Beispiel gewählt, dass die Personen ein Alter zwischen 20 und 30 Jahren besitzen sollen. Möchten Sie das auch so handhaben, so geben Sie in die Zelle A6 nun die folgende Formel ein (natürlich können Sie hier auch eine andere Zelle wählen):

=SUMME((DATEDIF(B1:B100;HEUTE();"Y")20))

Diese Formel ist aber keine „normale“ Formel, sondern eine Matrixformel. Das bedeutet, dass die Formel nicht korrekt ausgeführt wird, wenn Sie sie einfach so eingeben. Um die Formel richtig auszuführen, müssen Sie noch drei Schritte unternehmen. Zuerst klicken Sie noch einmal die Zelle mit der Formel an. Haben Sie das gemacht, so klicken Sie nun auf die Bearbeitungszeile der Formel. Abschließend müssen Sie nur noch die Tasten STRG+SHIFT+Enter auf ihrer Tastatur drücken. Nun wird die Formel richtig ausgeführt und der Wert korrekt in der Zelle angezeigt. In meinem Fall habe ich nun „2“ angezeigt bekommen, da „Max“ und „Maria“ zwischen 20 und 30 Jahren alt sind (Stand: 22.06.2011).  Aber nicht nur die Ausgabe in der Zelle hat sich verändert, sondern auch die Formel selbst. Diese lautet nun:

{=SUMME((DATEDIF(B1:B100;HEUTE();"Y")20))}

Haben Sie andere Zellen gewählt, so müssen Sie die Zellbezüge in der Formel entsprechend anpassen. Desweiteren müssen Sie die Zahlen „30“ und „20“ entsprechend verändern, wenn Sie möchten, dass die Anzahl an Personen die ausgegeben werden ein anderes Alter besitzen. Natürlich können Sie auch die Operatoren () davor verändern.

02-excel-formeln-personen-mit-bestimmten-alter-zaehlen-rechnen-470.png?nocache=1308758978341

Berechnung der Anzahl der Personen mit einem bestimmten Alter – anderer Weg:

Bei diesen Beispiel haben Sie auch noch eine zweite Möglichkeit, eine Anzahl an Personen mit einem bestimmten Alter auszugeben als der gerade eben angesprochene Weg. Wie auch im Punkt zuvor, benötigen Sie trotzdem nur eine Formel und eine Zelle, der einzige Unterschied befindet sich also in der Formel. Die Formel selbst ist aber wie zuvor auch eine Matrixformel, die wie folg lautet:

=INDEX(HÄUFIGKEIT(DATEDIF(B1:B100;HEUTE();"Y");{20;30});2)

Wie bei allen Matrixformeln, müssen Sie nun wieder die Zelle anklicken. Danach klicken Sie bitte in die Bearbeitungszeile der Formel. Zuletzt drücken Sie noch STRG+SHIFT+Enter. Nun steht in der Zelle der richtige Wert. Haben Sie er korrekt gemacht, ist dieser natürlich identisch zu dem aus der Formel davor. Die neue Formel sieht nun so aus:

{=INDEX(HÄUFIGKEIT(DATEDIF(B1:B100;HEUTE();"Y");{20;30});2)}

Gegebenenfalls müssen Sie auch hier wieder die Zellbezüge verändern. Auch die Altersgrenze können Sie wieder verändern, indem Sie die Zahlen „20“ und „30“ ihren Wünschen entsprechend verändern. Bei dieser Formel gibt es aber keine Operatoren, die verändert werden können. Es wird einfach beim geringeren Wert größer als und beim größeren Wert kleiner gleich angenommen, also so, wie in der Formel im Beispiel zuvor.

03-excel-formeln-personen-mit-bestimmten-alter-zaehlen-anders-470.png?nocache=1308758995255

Nun wissen Sie, wie man mithilfe einer Formel in Excel die Anzahl an Personen ausgeben kann, die zwischen einem bestimmten Alter liegen. Dabei haben Sie zwei Formeln zur Verfügung, die die gleiche Aufgabe bewältigen.

Von |2018-07-25T14:22:33+00:00Juni 22nd, 2011|Kategorien: Tabellenkalkulation|0 Kommentare

Über den Autor:

Hinterlassen Sie einen Kommentar