Du bist hier::--Excel Formeln – Telefnonummer trennen

Excel Formeln – Telefnonummer trennen

Sie haben in Excel eine Zelle, in der eine Telefonnummer bestehend aus Vorwahl und der Rufnummer ist und Sie möchten diese beiden aufteilen? Hier erfahren Sie, wie einfach das geht.

Um die Telefonnummer aufzuteilen benötigen Sie natürlich wieder eine Formel. Das Schöne daran ist aber, dass sie sich auch auf das Trennzeichen zwischen Vorwahl und Rufnummer variabel einstellt. So können Sie ein Leerzeichen, einen Bindestrich oder einen Slash/Schrägstrich verwenden und die Formel wird trotzdem zuverlässig funktionieren.

Beginn:

Zu aller erst beschriften Sie die Zeile 1. In die Zelle A1 schreiben Sie bitte „Telefonnummer“, in B1 kommt „Vorwahl“ und in C1 schreiben Sie „Rufnummer“. Natürlich können Sie auch andere Begriffe benutzen. Anschließend schreiben Sie in die Zelle A2 die erste Telefonnummer, die aufgeteilt werden soll. Selbstverständlich können Sie die Beschriftung in der ersten Zeile auch weglassen, jedoch müssen Sie dann bei den Formeln weiter unten gut aufpassen, dass Sie auch immer die richtigen Zellbezüge wählen.

Vorwahl:

Jetzt können Sie mit einer Formel auch schon an die Vorwahl herankommen. Schreiben Sie dazu nun in die Zelle B2 die folgende Formel:

=WENN(LINKS(A2)*1>0;"";LINKS(A2;MIN(SUCHEN({" "."-"."/"};A2&" -/"))-1))

Haben Sie die Formel eingegeben, so werden Sie auch gleich das richtige Ergebnis sehen, da die Formel eine normale und keine Matrixformel ist. In meinem Beispiel wird hier nun also die „01234“ angezeigt.

(Zur Darstellung in Originalgröße Abbildungen anklicken)

01-excel-formeln-telefonnummer-trennen-b2-470.png?nocache=1308579537462

Rufnummer:

Bei der Rufnummer gibt es zwei verschiedene Formeln. Die eine ist von der Zelle B2 unabhängig und funktioniert also auch wenn Sie die Vorwahl nicht angezeigt bekommen möchten, die zweite hingegen benötigt die Vorwahl. Zu Beginn werde ich mich aber um den Fall kümmern, dass B2 nicht benötigt wird. Dazu müssen Sie in die Zelle C2 nun folgende Formel eintragen:

=WENN(LINKS(A2)*1>0;A2;GLÄTTEN(TEIL(A2;MIN(SUCHEN({" "."-"."/"};A2&" -/"))+1;19)))

Anschließend wird sofort die Nummer ausgegeben, nachdem Sie die Formel eingetragen haben.

02-excel-formeln-telefonnummer-trennen-c2-470.png?nocache=1308579626167

Rufnummer anderer Weg:

Wie schon gesagt, kann man an die Rufnummer aber auch über eine andere Formel herankommen. Vom Grundprinzip ist sie ähnlich wie die andere Formel für die Rufnummer. Der Teil, in welchem ähnlicher bzw. gleicher Code steht, wie in der Formel der Vorwahl wird nun durch die Zelle B2 ersetzt. Die anschließende Ausgabe liefert aber den gleichen Wert. Möchten Sie lieber diesen Weg der Anzeige benutzen, so verwenden Sie dafür diese Formel:

=WENN(LINKS(A2)*1>0;A2;GLÄTTEN(TEIL(A2;LÄNGE(B2)+2;19)))

03-excel-formeln-telefonnummer-trennen-c2-anders-470.png?nocache=1308579644479

Anwendungsmöglichkeiten:

Wie oben schon einmal ganz kurz angesprochen ist es bei dieser Formel relativ egal, wie die Vorwahl von der Rufnummer getrennt wird. Selbstverständlich können Sie keinen willkürlichen Zeichen als Trennungszeichen benutzen, die Standardtrennzeichen sind aber vorhanden. So können Sie Telefonnummern verwenden, die durch ein Leerzeichen, einen Bindestrich oder das Slash Zeichen verbunden werden verwenden. Sollten ihnen diese Zeichen nicht ausreichen, so können Sie mit der richtigen Einträgen in der Formel auch noch Trennzeichen hinzufügen (siehe „SUCHEN({" "."-"."/"}“). Desweiteren sind auch Rufnummern, die einen Bindestrich enthalten kein Problem. So können also in einer Telefonnummer zwei Bindestriche vorkommen, die trotzdem richtig zugeordnet werden.

04-excel-formeln-telefonnummer-trennen-fertig-470.png?nocache=1308579668687

Nun haben Sie gelernt, wie man mit wenigen Formeln in Excel eine Telefonnummer trennen kann. Selbstverständlich können Sie die Telefonnummerneinträge jetzt über die Excel eigene Möglichkeit sortieren.

Von |2018-07-25T14:23:39+00:00Juni 22nd, 2011|Kategorien: Tabellenkalkulation|0 Kommentare

Über den Autor:

Hinterlassen Sie einen Kommentar