Du bist hier::--Excel Formeln – Zellen mit bestimmter Anzahl an Zeichen zählen

Excel Formeln – Zellen mit bestimmter Anzahl an Zeichen zählen

In diesem Excel Artikel werde ich ihnen erklären, wie man es schafft, dass Excel in einem Bereich die Anzahl an Zellen ausgibt, welche eine bestimmte Zeichenlänge haben. Zu bewerkstelligen ist das mit ein paar kleinen Formeln.

Die Funktion ZÄHLENWENN ist ihnen als häufigen Nutzer von Excel wahrscheinlich schon bekannt. Allein reicht diese Funktion aber nicht immer aus, um an die Anzahl an Zellen zu kommen, in denen eine gewünschte Anzahl an Zeichen genau erreicht, über- oder unterschritten wird. Wie Sie gleich sehen werden, bauen jedoch viele dieser Formeln auf die Funktion ZÄHLENWENN auf, was den Umgang mit den Formeln etwas erleichtern kann.

Beginn:

Zu aller Erst müssen Sie natürlich erst einmal die Zellen eintragen, die auf die Anzahl ihrer Zeichen untersucht werden sollen. Am geschicktesten wäre es, wenn Sie dafür die Zellen in der Spalte A benutzen, damit Sie die unten aufgeführten Standardformeln einfach so übernehmen könnten, ohne vorher noch Veränderungen zu treffen. Natürlich können Sie auch andere Zellbezüge auswählen, jedoch müssen Sie sie dann immer in die Formel einbauen. Um zu demonstrieren wie die Formel funktioniert, habe ich in der Spalte A 6 verschiedene Zellen „erstellt“, in denen manchmal mehr und manchmal weniger als fünf Zeichen eingetragen sind. Außerdem existieren auch Zellen nur mit Zahlen, was später noch wichtig sein wird.

Wert soll genau erreicht werden:

Sie können bei der Art der Zählweise zwischen drei verschiedenen Gruppen auswählen. Die erste Gruppe ist die, dass die Zeichen in der Zelle genau die gewünschte Anzahl an Zeichen besitzen. Die zweite Gruppe ist die für die Zellen, die mindestens die gesuchte Zahl an Zeichen besitzen und die dritte Gruppe ist für die Zellen, die höchstens die gesuchte Zahl an Zeichen besitzen. Zuerst werde ich mich darum kümmern, dass die Anzahl an Zeichen genau erreicht wird. Dabei kann man unterscheiden, ob in der Zelle nur Text bzw. Strings, oder (Text und) Zahlen vorhanden sind.

(Zur Darstellung in Originalgröße Abbildungen anklicken)
01-excel-formeln-zellen-mit-bestimmter-anzahl-an-zeichen-zaehlen-beginn-200.png?nocache=1308767897196

 Nur Text bzw. String (ohne Matrixformel):

Zuerst möchte ich ihnen zeigen, wie man die Anzahl an Zellen bekommt die nur Text enthalten und genau die gesuchte Menge an Zeichen besitzen. Dafür benötigen Sie selbstverständlich eine Formel. Hier kommt die oben angesprochene ZÄHLENWENN Funktion zum Einsatz. Schreiben Sie nun in die Zelle B1 die folgende Formel hinein:

=ZÄHLENWENN(A:A;"?????")

Da es keine Matrixformel ist, wird ihnen umgehend die korrekte Anzahl an Zellen mit den gewünschten Bedingungen ausgegeben. Die Stelle „?????“ in der Formel bedeutet übrigens nur, dass die Zelle fünf Zeichen besitzen muss und nicht mehr oder weniger haben darf. Wäre das der Fall, würde man in der Formel noch Sternchen finden.

02-excel-formeln-zellen-mit-bestimmter-anzahl-an-zeichen-zaehlen-genau-x-text-470.png?nocache=1308767928364

Auch reine Zahlen:

Jetzt wissen Sie, wie das Zählen funktioniert, wenn nur Texte oder Strings überprüft werden sollen. Sollen jetzt aber auch noch Zahlenfolgen ohne Buchstaben auftreten, wie zum Beispiel „12345“, benötigen Sie wieder eine neue Formel. Löschen Sie jetzt den aktuellen Inhalt der Zelle B1 und geben Sie folgende neue Formel ein:

=SUMME(1*(LÄNGE(A1:A100)=5))

Diese Formel ist eine Matrixformel. Das bedeutet für Sie, dass die Formel nicht einfach funktioniert, wenn Sie sie eingeben. Stattdessen müssen Sie nachdem Sie die Formel eingegeben haben noch die folgenden drei Schritte befolgen: Zuerst klicken Sie nochmals in die Zelle. Haben Sie das gemacht, so klicken Sie nun in die Bearbeitungszeile der Formel. Abschließend drücken Sie auf der Tastatur die Tasten STRG+SHIFT+Enter. Nun erscheint in der Zelle der korrekte Wert. In meinem Fall war das die Zahl „3“, da die Zellen A1, A3 und A5 von der Formel angesprochen werden. Neben der Ausgabe in der Zelle verändert sich aber auch die Formel. Korrekt sieht diese nun so aus:

{=SUMME(1*(LÄNGE(A1:A100)=5))}

Die Zahl „5“ in der Formel gibt logischerweise an, wie viele Zeichen die Zelle besitzen soll. Diese können Sie ihren Ansprüchen entsprechend anpassen, ebenso wie den Zellbezug in der Formel.

03-excel-formeln-zellen-mit-bestimmter-anzahl-an-zeichen-zaehlen-genau-x-matrix-470.png?nocache=1308767948508

Wert soll mindestens erreicht werden:

Wie vorhin schon angesprochen gibt es neben dem Ziel, dass der Wert genau erreicht werden soll auch noch die beiden anderen, dass der Wert mindestens erreicht werden soll oder dass der Wert die „Höchstens“-Angabe ist. Nun werde ich mich dem Tatbestand widmen, dass der Wert als das Minimum angesehen wird.

Nur Text bzw. String (ohne Matrixformel):

Wie im Abschnitt zuvor kann man auch hier wieder dazwischen unterschieden, ob der Inhalt der Zelle eine reine Zahl ist, oder ob es nur aus Text besteht oder eine Kombination aus Text und Ziffern ist. Zu Beginn werde ich mich um den letzteren Fall kümmern. Selbstverständlich benötigen Sie wieder eine neue Formel. Löschen Sie also den Inhalt von der Zelle B1 und schreiben Sie nun folgendes hinein:

=ZÄHLENWENN(A:A;"?????*")

Haben Sie die Formel eingegeben, so wird ihnen auch umgehend das richtige Ergebnis angezeigt. In meinem Fall ist es die Zahl „3“, da die Zelle A1, A3 und A6 jeweils mehr als fünf Zeichen besitzen und keine reine Zahl sind. Dass auch nach mehr als fünf Zeichen gesucht werden kann sehen Sie daran, dass nach den fünf Fragezeichen noch ein Sternchen kommt, was bedeutet, dass danach auch noch mehr Fragezeichen (also Zeichen) folgen könnten.

04-excel-formeln-zellen-mit-bestimmter-anzahl-an-zeichen-zaehlen-mind-x-text-470.png?nocache=1308767965908

Auch reine Zahlen:

Wie schon bei den Zellen, die die Anzahl an Zeichen genau erreichen mussten, kann man auch jetzt die Suche von Zahlen miteinschließen. Dabei wird dann wirklich auch nach Zahlen gesucht, die zum Beispiel wie diese aussehen: 123456. Nimmt man die Formel aus dem Schritt zuvor, so werden nur Zahlen gesucht, wenn bei ihnen auch noch Text mit dabei ist (Beispiel: „Test 1“ oder „123A“). Diese Fälle werden aber als String bezeichnet. Die Formel für dieses Vorhaben lautet:

=SUMME(1*(LÄNGE(A1:A100)>=5))

Wie auch vorhin schon, ist diese Formel eine Matrixformel. Also müssen Sie nachdem Sie die Formel eingegeben haben wieder die Zelle anklicken. Anschließend klicken Sie noch in die Bearbeitungszeile der Formel. Haben Sie das gemacht, so drücken Sie nun noch STRG+SHIFT+Enter auf ihrer Tastatur. Nun sehen Sie den korrekten Wert. Bei mir also die Zahl „4“, da nun auch die Zelle A5 mit der reinen Zahl untersucht wurde. Auch die Formel hat sich wie immer bei Matrixformeln verändert:

{=SUMME(1*(LÄNGE(A1:A100)>=5))}

Abändern können Sie die Formel wieder, indem Sie den Zellbereich anstelle von „A100“ richtig definieren. Soll die Grenze für die Mindestanzahl an Zeichen nicht fünf sein, so ändern Sie „5“ in der Formel bitte ab.

05-excel-formeln-zellen-mit-bestimmter-anzahl-an-zeichen-zaehlen-mind-x-matrix-470.png?nocache=1308767994404

Wert soll höchstens erreicht werden:

Die letzte der drei verschiedenen Möglichkeiten die Anzahl an Zellen auszugeben, die in Verbindung mit den Zeichen stehen ist die, dass eine bestimmte Zahl höchstens erreicht werden darf. Im Gegensatz zu den anderen beiden Fällen gibt es nun wieder eine „Universalformel“, die für Texte, Strings und Zahlen funktionieren, jedoch keine extra Formel für Texte. Die Formel ist hierbei keine Matrixformel und sie lautet:

=ANZAHL2(A:A)-ZÄHLENWENN(A:A;"??????*")

Haben Sie die Formel eingegeben, so wird ihnen hier wieder umgehend das Ergebnis angezeigt. Die Anzahl an Zeichen, die höchstens erreicht werden dürfen, können Sie wieder über die Anzahl an Fragezeichen regulieren.

06-excel-formeln-zellen-mit-bestimmter-anzahl-an-zeichen-zaehlen-hoechst-x-beide-470.png?nocache=1308768016748

Nun wissen Sie über alle Möglichkeiten Bescheid, wie man die Anzahl an Zellen auslesen kann, die mit einer bestimmten Zeichenlänge im Zusammenhang stehen (kleiner gleich, gleich, größer gleich). Dabei haben Sie fast immer zwei Formeln zur Auswahl, wobei die Matrixformel empfehlenswerter ist, wenn Sie nicht sicher wissen, was für eine Art von Zeichen in den einzelnen Zellen stehen.

Von |2018-07-25T14:22:33+00:00Juni 22nd, 2011|Kategorien: Tabellenkalkulation|0 Kommentare

Über den Autor:

Hinterlassen Sie einen Kommentar